我怎样才能让INC ::模块::安装Ubuntu的建议包? 我是不是该?

我想部署一个应用程序,我写到一个新的虚拟机,并​​使用CPAN安装所有我我Makefile.pl内所列的依赖关系后,遇到了一些兼容性问题。 除此之外,一些模块实际上只是一般都与一些Ubuntu的软件包一体化更好(即让地穴:: SSLeay的工作,或依赖于系统库的一些XML模块)。

所以我的问题是,无论是CPAN正在安装最新版本时,我的代码显然是对旧的只是工作的模块,并且它具有安装一些较新的在所有烦恼。

我的临时解决方案只是拿出Ubuntu的软件包列表,并作出易于得到安装,你必须Makefile.PL运行前行,但是这似乎是一个黑客。

有没有更好的方式来做到这一点?

分类:perl的 时间:2015-03-14 人气:3
分享到:

相关文章

Copyright (C) 55228885.com, All Rights Reserved.

55228885 版权所有 京ICP备15002868号

processed in 0.860 (s). 10 q(s)