找不到安装过程中的链接到MediaWiki的数据库驱动程序

MYSQL和Apache服务器已经安装在我的服务器上。 但我仍遇到这些问题。 我不明白的条款编译PHP的--with-mysql我应该在哪里编译? 我使用窗口服务器。 或如何安装mysql.so模块?

检查环境...

报告安装问题时,请包括以下的所有线路。 PHP 5.2.14安装找不到一个合适的数据库驱动程序! 对于MySQL,编译使用--with-mysql的PHP或安装mysql.so模块对于PostgreSQL,使用--with-pgsql的编译PHP,或者安装pgsql.so模块对于SQLite的,使用--with-PDO_SQLITE编译PHP,或安装pdo_sqlite.so模块对于MSSQL,使用--with-mssql_not_ready编译PHP,或者安装mssql_not_ready.so模块对于DB2,使用--with-IBM_DB2编译PHP,或者安装ibm_db2.so模块对于Oracle,编译PHP使用--with-OCI8,或安装oci8.so模块

--------------解决方案-------------

看看在/ php_install_dir /扩展。 应该有一个名为“php_mysql.dll”文件。 如果是这样,使它能够在php.ini中。 如果没有,请下载该dll,将其复制到扩展目录,并启用在php.ini中。 记住要重新启动Apache。

更多信息(请务必阅读评论)查看此页面。

在php.ini中改变这一点。 如果没有安装有Windows安装这样做呢?

; enable_dl = Off

; CHANGED - This is necessary to enable dynamic loading of Windows .dll modules

; The immediate problem was that PHP could not find a database driver for MySQL

enable_dl = On

分类:php 时间:2015-03-15 人气:0
分享到:

相关文章

Copyright (C) 55228885.com, All Rights Reserved.

55228885 版权所有 京ICP备15002868号

processed in 0.594 (s). 10 q(s)