git的安装问题

我得到一个错误信息,当我在命令制式当我在当前的git目录,我该如何解决这个问题?

这是我输入和接收:

CD的git-1.7.5.4

GIT-1.7.5.4 $使

〜庆典:品牌:命令未找到。

我如何缓解这个问题,所以我可以运行混帐化妆命令和卷曲?

--------------解决方案-------------

你需要安装制作。 最有可能你没有安装操作系统的工具链。 我相信,在Mac OS X,你需要安装的XCode,但有可能是另一种方式。

针对Git特有的注意:您需要设置您的config.mak选项。 值得注意的是,你应该有NO_TCLTK=YesPlease如果你没有的Tcl / Tk。 一些其他的选择可能是必要的。 此外,如果你没有libcurl的头,用NO_CURL=YesPlease (警告:您将无法使用HTTP或HTTPS服务器)。 如果你没有OpenSSL的头,用NO_OPENSSL=YesPlease 。 等等。 看在Makefile文件的更多细节。

据Makefile文件,因为你使用的是达尔文,你需要

NEEDS_CRYPTO_WITH_SSL=YesPlease
NEEDS_SSL_WITH_CRYPTO=YesPlease
NEEDS_LIBICONV=YesPlease

如果你打算使用的测试套件, NO_SVN_TESTS=YesPlease可以加速时间这样做。

考虑启用BLK_SHA1=YesPlease如果适用于Mac OS X的(不知道在这一个)

你安装的XCode?

在一个侧面说明,为什么你自己编译它,而不是使用预编译的二进制或安装从包管理器,如自制?

是否有任何理由,为什么你想从源代码编译,而不是使用打包安装?

分类:混帐 时间:2015-03-14 人气:4
本文关键词: OSX,混帐
分享到:

相关文章

Copyright (C) 55228885.com, All Rights Reserved.

55228885 版权所有 京ICP备15002868号

processed in 0.753 (s). 10 q(s)